SPAS 3.0 Forums: General

You have been banned from this forum. If you have any questions, please contact the Administrator.

Sign in or create an account

You are logged in as:

Getting started with SPAS and Flashdevelop

Page : 1

Reply New topic
Author Message
Community Member
Join Date: 2012-02-16
Posts: 3
Post date 02-16-2012, 18:45
#1
Hello everybody,

I'm verry interested in SPAS 3.0...But what i really don't get is how to get started with SPAS and FlashDevelop. I was following some tutorials but it appears that i somewhere missed the way i have to set up my project in FD. I use FD all the time creating Flash IDE projects, but with this one i'm stuck. So any advise would be welcome ?
Tx

Administrator
Join Date: 2008-12-01
Location: French Riviera
Posts: 47
Post date 02-16-2012, 18:59
#2
Hi Stefdv,
Welcome to the SPAS community.

The way to start with FD is quite easy:
1) download the lastest SPAS SWC library file
2) create a new AS3 project
3) paste the SWC library into the lib folder
4) try the cookbook tutorial series: http://www.flashapi.org/spas-cookbook.php .
5) post your question on this forum...

Hope this will help cool

Creator of SPAS 3.0
Community Member
Join Date: 2012-02-16
Posts: 3
Post date 02-16-2012, 20:22
#3
Wow, that was fast...Wasn't even sure this was still alive happy
Anyway tx for your reply, posted this to early i guess ( found the CubicForm tutorial ).

The problem with the Cubicform is the use of 'Position' i can only find AnchorPosition in org.flashapi.swing.constants.
I'm also not able to use event.uio like they use in the tutorial.
any thoughts on that ?

Administrator
Join Date: 2008-12-01
Location: French Riviera
Posts: 47
Post date 02-16-2012, 20:35
#4
The Cubicform whitepaper is an old tutorial, the API has changed a little bit since we published it:
- the Position class does not exist anymore, so you need to find the corresponding classes in the reference (here it is the AnchorPosition class),
- the uio property is no longer available; use the target property instead.


Creator of SPAS 3.0
Community Member
Join Date: 2012-02-16
Posts: 3
Post date 02-16-2012, 21:44
#5
Got it...The only problem is that i get an error when i use AnchorPosition.TOP or BOTTOM. LEFT and Right are working allright.

Administrator
Join Date: 2008-12-01
Location: French Riviera
Posts: 47
Post date 02-19-2012, 16:03
#6
Well, it'is strange because I've just fixed a minor bug with AnchorPosition.RIGHT in the L&F classes, but AnchorPosition.TOP or AnchorPosition.BOTTOM work fine.

Any code to show?

Creator of SPAS 3.0

Page : 1